8 Aumento Sueldo de un Trabajador – Algoritmo y Javascript – IF – ELSE

Pseudocódigo y Javascript que lea como dato el sueldo de un trabajador, aplique un aumento del 15% si su sueldo es inferior a 1000 y 10% en caso contrario.

En el siguiente Video Tutorial se explica el ejercicio resuelto:

Algoritmo:

**** SOLUCION ****

Inicio
	//Definir variables:
	variable real: sueldo,aum,nuevoSue
	
	//Lectura de datos:
	Escribir("Ingresar sueldo")
	Leer(sueldo)
	
	//Calcular:
	Si(sueldo < 1000) entonces 
		aum ← 0.15*sueldo
	Sino 
		aum ← 0.10*sueldo
	Fin_si
	
	nuevoSue ← sueldo + aum
	
	Escribir("Sueldo actual ",sueldo)
	Escribir("Aumento ",aum)
	Escribir("Nuevo Sueldo ",nuevoSue)
Fin

Código Javascript:

<script>
	var sueldo,aum,nuevoSue;

	sueldo = parseFloat(prompt("Ingresar sueldo"));

	if (sueldo < 1000) {
		aum = 0.15*sueldo;
	}else{
		aum = 0.10*sueldo;
	}

	nuevoSue = sueldo+aum;

	document.write('Sueldo actual '+sueldo);
	document.write('Aumento '+aum);
	document.write('Nuevo Sueldo '+nuevoSue);
</script>
ESCRIBE AQUÍ TUS CONSULTAS O PREGUNTAS Y TE RESPONDEREMOS EN BREVE

Escribe tu pregunta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *