7. Calcular el mayor de 3 números – Algoritmo y Javascript

Pseudocódigo y JavaScript para hallar el mayor de 3 números utilizando If Else. Ejercicio básico de Fundamentos de programación

En el siguiente Video Tutorial se explica paso a paso el proceso para crear el pseudocódigo y código

Pseudocódigo Algoritmo

**** SOLUCION ****

Inicio
	//Definir variables:
	variable real: n1,n2,n3,t,mayor
	
	//Lectura de datos:
	Escribir("Ingresar los 3 números")
	Leer(n1,n2,n3)
	
	//Calcular el mayor:
	Si(n1 > n2) entonces 
		t ← n1
	Sino 
		t ← n2
	Fin_si
	
	Si(t > n3) entonces 
		mayor ← t
	Sino 
		mayor ← n3
	Fin_si
	
	Escribir("El mayor es ",mayor)
	
Fin

Código JavaScript

<script>
	var n1,n2,n3,t,mayor;
	n1 = parseInt(prompt("Número 1"));
	n2 = parseInt(prompt("Número 2"));
	n3 = parseInt(prompt("Número 3"));

	if (n1 > n2) {
		t = n1;
	}else{
		t = n2;
	}

	if (t > n3) {
		mayor = t;
	}else{
		mayor = n3;
	}

	document.write("El mayor es "+mayor);
</script>
ESCRIBE AQUÍ TUS CONSULTAS O PREGUNTAS Y TE RESPONDEREMOS EN BREVE

Escribe tu pregunta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *